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Enhancements

1) Non-dissipative element design for slab as per NTC2018

2) Improvement of design speed for non-dissipative element

3) Apply partial safety factor in inelastic material model

4) Add column design by constant P

5) Improvement of joint design as per EC2 and NTC

6) Improvement of slab design as per EC2 and NTC

7) Cyclic shear resistance check as per NTC2018

8) Insert strength loss option for EC8 hinge type

9) Improvement about masonry pushover analysis and post processing

10) Improvement of hinge model as per EC

11) Energy result graph & additional damping ratio in time-history analysis results

12) Add reaction table for each step in pushover

13) Revit 2020 interface

14) Select Inelastic Hinge Result Output in Inelastic time history analysis

15) Improvement in analysis speed for inelastic time history analysis

16)  Add result summary table of fiber beam, wall for inelastic hinge 

• midas Gen
4

• midas Design+
1) Steel  design tool as per AISC

2) Anchor bolt module as per ACI
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1. Non-dissipative element design for slab as per NTC2018

Add Non-dissipative element design for Slab.

Strength (ULS)

: Shear design uses only load Comb. Of Gravity loads

Strength (ELS) (Add)

: Flexural design uses only ELS load Comb..

•Slab Design as Non-dissipative element

B (Width by unit)

H

•M-Curvature Curve of Slab
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2. Improvement of design Speed for Non-dissipative element 

Improvement of design Speed for Non-dissipative element  

→ Add Approximate Method
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Add Option
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Add inelastic model types for Conc. And Rebar (apply partial safety factor)
-Concrete : Parabola Rectangle or Bilinear model
-Rebar : bilinear model (SP63Add inelastic model types for Conc. And Rebar (apply 
partial safety factor)-Concrete : Parabola Rectangle or Bilinear model-Rebar : bilinear 
model (SP63)

* Default : 1.0

Apply “Partial Safety Factor” in Inelastic Material Model

3. Apply partial safety factor in inelastic material model

* Default : 1.0
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4. Add Column Design by Constant P

Add Column Design by Constant P

→ Add P-M Curve Calculation Method Option 

Gen 2020 v1.1 Gen 2020 v2.1

Constant PP-M proportional

Add Option
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5. Improvement of Joint design as per EC2 and NTC

Joint Design as per EC and NTC

→ It is possible to skip a Joint design for “Not confined” condition

Add Option
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Add Hoop Spacing of Joint in Design

Printout “Check Spacing”

In graphic,

5. Improvement of Joint design as per EC2 and NTC

Detail report

Design result table

Graphic result

Printout “J” in red 

color

In Design result table

If applied spacing s < s,min,

Printout “AN INCONGRUENT 

SPACING !!!” In Detail report
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5. Improvement of Joint design as per EC2 and NTC

Joint Design as per EC and NTC

→ Improvement to check a hoop area and spacing in Joint design

ㄴㄴㄴㄴDetail report

Design result table

Graphic result
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6. Improvement of slab design as per EC2 and NTC

Add “Check ratio of x/d” and “Check Stress by Quasi-permanent Load combinations”

Check x/d as per NTC2018  4.1.2.1.2.1 Add stress check by Quasi-permanent
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7. Cyclic shear resistance check as per NTC2018

Check of Cyclic shear Resistance as per NTC2018 in Existing RC building

Capacity : Vr by Equation below

Demand : Design Shear Force

Result Table for Cyclic shear Resistance checking 

Demand  ≤ Capacity → O.K 

Demand  > Capacity → N.G.

Set Cyclic Shear Resistance Parameters

- ULS Design
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Check of Cyclic shear Resistance as per NTC2018 in Existing RC building 

Capacity : Vr by Equation below

Demand : Shear Force in Step n

Result Table for Cyclic shear Resistance checking 

Demand  ≤ Capacity → O.K 

Demand  > Capacity → N.G.

- Result of Pushover Analysis

Set Cyclic Shear Resistance Parameters

7. Cyclic shear resistance check as per NTC2018
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8. Insert strength loss option for EC8 hinge type

Insert Strength loss option for EC8 hinge type
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Improvement about Masonry pushover analysis and post processing

→ Add “q*” in Text Output

9. Improvement about masonry pushover analysis and post processing
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Target Displacement Capacity of SLV and SLC in Masonry

9. Improvement about masonry pushover analysis and post processing

Last displacement of bilinear x gamma

Last displacement of bilinear x 3/4

Add Remark here

SLV

SLC

Displacement of limit elastic dSLD x 2/3

Ve

SLO

Capacity of SLD 

= Min.Displacement of Ve and ¾ Vu

*Ve = max shear of bilinear

*Vu = max shear of MDOF curve 

Vu

SLD
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Updating My Masonry Pier hinge Type 

→ Masonry > Pier Type

9. Improvement about masonry pushover analysis and post processing

Point
New

Building

Existing

Building

C 0.01 0.01

D 0.01 0.01

Values of D/H



Gen 2020 v2.1 Release Note

18 /39

midas Gen

Updating My Masonry Pier hinge Type 

→ Masonry > Spandrel Type

9. Improvement about masonry pushover analysis and post processing

Point
New

Building

Existing

Building

C 0.008 0.015

D 0.008 0.015

Values of D/H



Gen 2020 v2.1 Release Note

19 /39

midas Gen

Updating Fy Masonry Spandrel hinge Type 

9. Improvement about masonry pushover analysis and post processing

Shear Resistance = 

Min. [                                          ]

where

𝑉𝑡 = ℎ𝑡𝑓𝑣𝑘𝑜, 𝑉𝑝 = 2𝑀𝑢/𝑙

Shear Resistance = 

Min. [                                                                             ]

where

𝑉𝑡 = 𝐿𝑇1.5𝑓𝑣𝑘𝑜/𝛽 × 1 + 𝑃/1.5𝑓𝑣𝑘𝑜, 𝑉𝑝 = 2𝑀𝑢/𝑙
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Old version New version

Improvement of Hinge model as per EC

10. Improvement of hinge model as per EC
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11. Energy result graph & additional damping ratio in time-history analysis results

Improvement of Energy Result Graph : Energy Percentage Result of all step

[Exiting] Energy Percentage Final Step Result

[New] Energy Percentage Result of all step

→ Click to display text window
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11. Energy result graph & additional damping ratio in time-history analysis results

Add Additional Damping Ratio of Energy Dissipation System

[New] Additional Damping Ratio Result of 

final step

→ Click to display text window
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11. Energy result graph & additional damping ratio in time-history analysis results

[New] Energy Percentage Result of all step

→ Click to display text window

Add Additional Damping Ratio of Energy Dissipation System
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12. Add reaction table for each step in Pushover

Add Reaction Table for each step in PUSHOVER

Step 1. Open Records Activation Dialog box.

Step 2. Select Load case for pushover.

Step 3. Select Pushover step.

Step 4. Printout Reaction table 

2

3

4
1
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13. Revit 2020 Interface

Gen-Revit Link
Functions Revit <> Gen

Linear 

Elements

Structural Column  <>

Beam  <>

Brace  <>

Curved Beam  >

Beam System  >

Truss  >

Planar

Elements

Foundation Slab  <>

Structural Floor  <>

Structural Wall  <>

Wall Opening & Window  >

Door  >

Vertical or Shaft Opening  >

Boundary

Offset  >

Rigid Link  >

Cross-Section Rotation  >

End Release  >

Isolated Foundation Support  >

Point Boundary Condition  >

Line Boundary Condition  >

Wall Foundation  >

Area Boundary Condition  >

Load

Load Nature  >

Load Case  >

Load Combination  >

Hosted Point Load  >

Hosted Line Load  >

Hosted Area Load  >

Other 

Parameters

Material  <>

Level >

Send Model to midas Gen

Revit 2020 Gen2020

▪ File > Import > midas Gen MGT File

▪ File > Export > midas Gen MGT File
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14. Select Inelastic Hinge Result Output in Inelastic time history 

analysis

▪ Select the element to print  

▪ Global Control Setting

▪ Inelastic Hinge Status Result

- Press ‘Add/Replace’ button after 

selecting element on model view

-

- Set to output  selected elements - Check result of selected elements

- By setting to output only the results of the selected element, 

- It can be  shorten the analysis time and check the required results.

▪ Select General Link to print 

▪ Properties > Inelastic Properties > Inel. Control Data > Select Inelastic Hinge Result Output(Element/General Link)

▪ Load > Dynamic Loads > Time History Analysis Data > Global Control 

- Press ‘Add’ button after 

- Selecting GL-Link
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▪ Properties > Inelastic Properties > Inel. Control Data > Select Inelastic Hinge Result Output(Element/General Link)

▪ Load > Dynamic Loads > Time History Analysis Data > Global Control 

14. Select Inelastic Hinge Result Output in Inelastic time history 

analysis

▪ Global Control Setting ▪ Inelastic Hinge Status Result

- Set to Max/Min Result Only

- Check Max/Min result output
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▪ Reduction of analysis time by optimizing the inelastic time history analysis program and improving the output algorithm for inelastic 

analysis results

15. Improvement in analysis speed for inelastic time history analysis

3D Fiber Wall Model (23F) 3D  Structure Hinge Model (12F)
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▪ Results > Results Tables > Inelastic Hinge > Fiber Beam Summary, Fiber Wall Summary 

16. Add result summary table of fiber beam, wall for inelastic hinge 

▪ Fiber Beam Summary

▪ Fiber Wall Summary
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1. Steel design tool as per AISC

Unbraced Length

of Beam bracing

Ry = 1.1 usually.  When Ry=1.1,  AISC is the same as Korean code
Beam bracing
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1. Steel design tool as per AISC

Brace Strength

(Beam)

Beam bracing
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1. Steel design tool as per AISC

Brace Strength

(Beam)
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1. Steel design tool as per AISC

Link Stiffener Design
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1. Steel design tool as per AISC

Link Stiffener Design
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1. Steel design tool as per AISC

Beam Strength

(Beam design 

with K-brace)



Gen 2020 v2.1 Release Note

37 /39

midas Gen

2. Anchor bolt module as per ACI

RC > Anchor Bolt ▪ Applied Code : ACI318-14(M),11(M),08(M),NSR-10

▪ Spacing, Tensile,ShearStrength, Combined Ratio Check for Post-Installed / Cast-In-Place Anchor Bolt 
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2. Anchor bolt module as per ACI

Section Force Anchor Layout

Step 1.

Define concrete, Anchor bolt 

material and element 

information.

Step 2.

Define Force Data.
(Axial,Moment,Shear,Torsion)

Procedure of Anchor Bolt Design

Step 3.

Define Anchor Bolt information.

Cast-In-Place Anchor : Headed Stud/Headed Bolt/Hooked Bolt(L/J)

Post-Installed Anchor:

Expansion(Torque,Displacement),Undercut,Adhesive anchors

Step 4.

Define  the layout type & spacing

Number of Anchor bolt.
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2. Anchor bolt module as per ACI

Summary Calculation Report Detail Calculation Report

- Choose Summary/Detail Calculation Report

- Easy to check by printing standard(code)chapter in detail 

calculation report.


