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 Mejora

1) Código de Concreto Reforzado: ACI3 18-19 (para US.SI)

2) Verificación del nodo Viga-Columna para Edificios Existentes según NTC2018

3) Comprobación de control de grietas para columna de concreto según EC2:04 y NTC

4) Metodología de revisión/diseño de columna fuerte-viga débil según ACI 

5) Código Tailandés: DPT (Carga sísmicas y de viento)

6) Adición de base de dato de Tailandia (TIS para SI,MKS)

7) Adición de base de dato de Tailandia (CNS560-18)

8) Adición de base de dato de Indonesia (SNI)

9) Calculadora de escalado de sismos

10) Función de vista previa de la página de inicio

11) Interfaz de Revit 2022

• midas Gen
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Gen 2022 v1.1 Nota de Lanzamientomidas Gen

1. Código de Concreto Reforzado: ACI 318-19 (para US.SI)

Tabla de resultados de diseño

Reporte Gráfico

Se agregó el código ACI 318-19 (EE. UU.)/ACI318M-19 (SI) para el diseño de Concreto Reforzado
Código de diseño de concreto

Reporte detallado
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Gen 2022 v1.1 Nota de Lanzamientomidas Gen

Se agregaron combinaciones de carga por ACI 318-19      

Provisión Factores de carga y combinaciones Observación

Combinaciones de 
carga para 
resistencia

1.4 (D+F)

• D : Carga Muerta
• F : Carga de Fluido
• T : Carga por temperatura
• H : Carga de presión lateral del suelo (seco o 

saturado)
• L : Carga viva
• Lr : Carga viva de azotea
• R : Carga de lluvia
• W : Carga de viento
• E : Carga sísmica (=Eh + Ev)
• Em : efecto máximo de la fuerza sísmica 

horizontal y vertical (=Ω0Eh)
• Ω0 : Factor de amplificación de la fuerza sísmica
• Eh : Carga sísmica horizontal
• Ev : Carga sísmica vertical (no proporcionado en 

Gen 2022 v1.1)

1.2(D+F+T) +1.6(L+H) + 0.5(Lr or R)
1.2D +1.6(Lr or R) + (1.0L or 0.5W)
1.2D ± 1.0W + 1.0L +0.5(Lr or R)
1.2D ± 1.0E + 1.0L
0.9D ± 1.0W + 1.6H
0.9D ± 1.0E + 1.6H

Combinaciones de 
carga de esfuerzos 

admisibles

D + F
D + H + F + L + T
D + H + F + (Lr or R)
D + H + F + 0.75[L+T(Lr or R)]
D + H + F ± (0.6W or E / 1.4)

Combinaciones 
de carga 

especiales

1.2D + 1.0L +1.0Em

0.9D ± 1.0Em
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1. Código de Concreto Reforzado: ACI 318-19 (para US.SI)

Para concreto reforzado



Gen 2022 v1.1 Nota de Lanzamientomidas Gen

1. Código de Concreto Reforzado: ACI 318-19 (para US.SI)

Se agregaron nuevos materiales y base de datos 
de barras de refuerzo según ASTM19

Establecer material de barras de refuerzo Base de datos y configuración de barras según ASTM19

Resistencia de la barra según ASTM 19

Resistencia a tensión

Fu (psi)

Resistencia a fluencia

Fy (psi)
Grade 40 60,000 40,000
Grade 60 80,000 60,000
Grade 80 100,000 80,000

Grade 100 117,000 10,000
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Gen 2022 v1.1 Nota de Lanzamientomidas Gen

Demanda : Joints Stress, σjt  y σjc

Capacidad : siguiente ecuación

Demanda ≤ Capacidad 🡪 O.K

Demanda > Capacidad 🡪 N.G.

Establecer parámetros de chequeo de nodos

Tabla de resultados para chequeo de capacidad de nodos para edificios existentes
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2. Verificación del nodo Viga-Columna para Edificios Existentes según NTC2018

Comprobación de la capacidad de los nodos viga-columna para un edificio existente

• Design > result > Concrete Design > Existing Joint Check

Esfuerzos a tensión

Esfuerzos a compresión



Gen 2022 v1.1 Nota de Lanzamientomidas Gen

Tabla de resultados Beam-Column Joint check (Estructuras existentes)

2. Verificación del nodo Viga-Columna para Edificios Existentes según NTC2018

Comprobación de la capacidad de los nodos viga-columna para un edificio existente

• Design > result > Concrete Design > Existing Joint Check

Donde,
1) N : Fuerza axial actuando en la columna 
superior (+) compresión, (-) tensión)

2) Vj : Cortante total actuando en el nudo, obtenido 
como la suma algebraica del cortante transmitido por 
la columna superior y los esfuerzos horizontales 
transmitidos por la parte superior de las vigas.

3)Aj : bj * hjc
Donde bj y hjc están deinidos en 7.4.4.3.1 de la NTC

✔ Nota

C8.7.2.3.5 Vigas y columnas de edificios existentes según CIRCOLARE NTC2018

[Cálculo y chequeo del esfuerzo a tensión diagonal del nudo viga-columna]

[Cálculo y chequeo del esfuerzo a compresión diagonal del nudo viga-columna]

1) Esta opción de chequeo se activa sólo con  NTC2018.

2) Si se selecciona la opción de aplicar provisiones 
sísmicas especiales para el diseño en concreto, esta 
opción no se puede activar.

3) Este chequeo debe ser realizado solamente para 
nudos no confinados según el numeral 7.4.4.3 de la  
NTC

4) Este chequeo es para estructuras existentes, por lo 
tanto es calculado usando el refuerzo de la viga 
ingresado por el usuario.

✔ Consejos
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Gen 2022 v1.1 Nota de Lanzamientomidas Gen

Definir parámetros para el diseño del nudo 

3. Control de grietas para columna de concreto según EC2:04 y NTC

Chequeo del ancho de grietas en columnas de RC según EC2:04 & NTC 2018

Chequeo de columna de CR

Realizar chequeos de servicio

Resultados gráficos

Reporte detallado

Cuando se define una sección fisurada,
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Gen 2022 v1.1 Nota de Lanzamientomidas Gen

Cálculo del área efectiva del concreto en tensión, Ac,eff 
[ Columnas rectangulares y circulares]

3. Control de grietas para columna de concreto según EC2:04 y NTC

Revisión del ancho de grietas según EC2:04 & NTC2018

- Para determinar εsm- εcm
1) εsm : Esfuerzo promedio de las barras de refuerzo para las 

combinaciones relevantes, incluyendo los efectos de 
deformaciones impuestas y del endurecimiento a tensión.

2) εcm : Esfuerzo promedio en el concreto entre grietas
3) σs :Esfuerzo en el acero a tensión
4) αe  : Es / Ecm.
5) Kt : factor dependiente de la duración de la carga

0.6 para cargas de corto plazo, 0.4 para cargas de largo plazo
6) ρp,eff : As / Ac,eff

- Para determinar Sr.max
1) ɸ : Diámetro de la barra. El programa considera solamente la 

capa de refuerzo más externa.
2) c : recubrimiento del refuerzo longitudinal
3) k1 : Coeficiente para considerar las propiedades de adherencia  

del refuerzo (0.8 for para barras de alta adherencia)
4) k2 : Coeficiente para considerar la distribución de las 

deformaciones (0.5 para flexión)
5) k3 : 3.4 (valor recomendado)
6) k4 : 0.425(valor recomendado)

1) La revisión de los esfuerzos en la sección agrietada se realiza 
para cada eje local. De igual manera, la revisión del 
agrietamiento se realiza respecto a los ejes locales (ejes y & z )

2) Con el módulo GSD también es posible realizar la revisión de 
esfuerzos en la sección agrietada y en cada barra de refuerzo.

3) Para calcular el área efectiva del concreto en tensión (Ac,eff), 
el programa usa la ecuación de Wiese et al mostrada en la 
imagen de la izquierda.

✔ Información
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2. Cálculo de S
r.max

✔ Nota

El ancho de la grieta se calcula a partir de la siguiente fórmula:

Wk = S
r.max 

( ε
sm

- ε
cm 

) ≤ Wk,max

1. Cálculo de ε
sm

- ε
cm



4. Metodología de revisión/diseño de columna fuerte-viga débil según ACI 

Se agregó el método de resistencia nominal para calcular las fuerzas de diseño para provisiones 
de diseño sísmico especiales

• Design > RC Design> Design Code > SCWB Design/Checking Method

Gen 2022 v1.1 Nota de Lanzamientomidas Gen

Nueva opción SCWB Design/Checking

1. Momento de diseño para las columnas cuando se utiliza la 
función “Ductile Design” para el método seleccionado

[Método Resistencia de Diseño] Se usa la resistencia de diseño de 
las vigas, ∅𝒃𝑴𝒏

[Método Resistencia Nominal] Se usa la resistencia nominal de las 
vigas, 𝑴𝒏

[Método Resistencia Nominal] Se usa la resistencia nominal de las 
vigas y las columnas, 𝑴𝒏𝒃, 𝑴𝒏𝒄

1)  Los códigos que aplican son ACI318-19, ACI318-14, NSR-10, NSCP2015

2)  Esta opción puede ser activada para:
① ACI 318-19,14 , NSCP-2015: Pórticos especiales SMF
② NSR-10 : Pórticos DES o pórticos DMO

2. Cálculo de la relación Columna Fuerte - Viga Débil cuando 
se utiliza la opción “SCWB Ratio”

[Método Resistencia de Diseño] Se usa la resistencia de diseño de 
las vigas y las columnas, ∅𝒃𝑴𝒏𝒃, ∅𝒄𝑴𝒏𝒄

✔ Notas
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✔ Notas



Gen 2022 v1.1 Nota de Lanzamientomidas Gen

5. Código Tailandés: DPT (Carga sísmicas y de viento)

Se agregó DPT.1311-50:2007 (Carga de viento)
Carga de Viento

Perfil de carga de viento según DPT1311-05 (2007)

Hoja de cálculo de carga de viento según DPT1311-05 (2007)
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Gen 2022 v1.1 Nota de Lanzamientomidas Gen

5. Código Tailandés: DPT (Carga sísmicas y de viento)

Agregado DPT.1301/1302-61:2018 (Carga sísmica)
Carga sísmica estática Espectro de Respuesta

Funciones de espectro de respuesta automáticos 

según DPT1301/1302-61(2018))

Definir factores según DPT1301/1302-61(2018)
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Gen 2022 v1.1 Nota de Lanzamientomidas Gen

6. Adición de base de dato de Tailandia (TIS para SI,MKS)

Resistencia a 

tensión

Fu (MPa)

Resistencia a 

fluencia

Fy (MPa)

Resistencia a 

fluencia

Fy (KSC)
SR 24 385 235 2400
SD 30 480 295 3000
SD 40 560 390 4000
SD 50 620 490 5000

Resistencia de la barra de refuerzo según TIS

Base de datos agregada para concreto y barras de refuerzo según TIS (para Sistema de unidades SI,MKS)
Material para barras de refuerzo

Resistencia del concreto según TIS

Base de datos de barras de refuerzo según TIS y 
configuración de diseño
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Gen 2022 v1.1 Nota de Lanzamientomidas Gen

7. Adición de base de dato de Tailandia (CNS560-18)

Base de datos 
agregada

                                 Material de las barras de 

  Resistencia de las barras de

para concreto y barras de 

refuerzo

refuerzo según CNS560-18

refuerzo según CNS560-18

Base de datos para concretos

Resistencia a fluencia

Fy (kgf/cm2)
SD280 2,800

SD280W 2,800
SD420 4,200

SD420W 4,200
SD490W 5,000
SD550W 5,600
SD690 7,000
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Gen 2022 v1.1 Nota de Lanzamientomidas Gen

8. Adición de base de dato de Indonesia (SNI)

Resistencia de las barras de refuerzo por SNI

Base de datos agregada para concreto y barras de refuerzo según SNISet 

    Material de barras de refuerzo

Grado
Resistencia a tensión

Fu (MPa)

Resistencia a fluencia

Fy (MPa)
BjTP 280 350 280
BjTS 280 350 280

BjTS 420A 525 420
BjTS 420B 525 420
BjTS 520 650 520
BjTS 550 687.5 550
BjTS 700 805 700

Resistencia del concreto por SNI

Base de datos de barras de refuerzo según SNI y configuración 
de diseño
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Gen 2022 v1.1 Nota de 
Lanzamientomidas Gen

9. Calculadora de escalado de sismos

Entrada Onda sísmica y 
espectro objetivo

Configuración del   método y el factor de escala

Comprobar resultados de 
escalado y de exportación

- Función: escalado para que el promedio del espectro SRSS de la onda sísmica como dato de 
entrada sea mayor o igual que el espectro objetivo para el período objetivo
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Gen 2022 v1.1 Nota de Lanzamientomidas Gen

9. Calculadora de escalado de sismos

-Tools > Generator > Earthquake Scaling

1

2

3

4

Ingresar la información de ondas sísmicas 

considerando las condiciones del terreno 

donde se ubica la estructura. Importe las 

ondas sísmicas guardadas como archivos 

SGS o copie y pegue los datos de entrada 

en formato Excel.

Establezca el espectro de diseño de 

acuerdo con el código de referencia e 

ingrese el factor de escala del espectro 

objetivo.

Establezca el período objetivo del 
escalado.

Importe y exporte datos de entrada como 
archivos wzd.

1

2

3

4
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Gen 2022 v1.1 Nota de Lanzamientomidas Gen

9. Calculadora de escalado de sismos

-Tools > Generator > Earthquake Scaling

▪ Ejemplo de exportación a Excel

▪ Ejemplo de exportación de la función 
T.H.E

5

6

7

5  Establezca el método y el factor de escala del escalado  
sísmico
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6     Compruebe los resultados del escalado en los gráficos de 
espectro y aceleración.

7     Los resultados de las ondas sísmicas escaladas pueden 
exportarse como archivos SGS o funciones de en el tiempo o 
guardarse como archivos de Excel.
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10. Función de vista previa de la página de inicio

-Mensaje de bienvenida personalizado
-Una sección para ver los modelos usados más recientemente
-Enlace a nuestro sitio de conocimiento técnico
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Funciones Revit <> Gen

Elementos 

lineales

Structural Column <>
Beam <>
Brace <>
Curved Beam >

Beam System >

Truss >

Elementos 

Planos

Foundation Slab <>
Structural Floor <>
Structural Wall <>

Wall Opening & Window >
Door >
Vertical or Shaft Opening >

Apoyos

Offset >
Rigid Link >

Cross-Section Rotation >
End Release >
Isolated Foundation Support >

Point Boundary Condition >
Line Boundary Condition >

Wall Foundation >
Area Boundary Condition >

Cargas

Load Nature >
Load Case >

Load Combination >
Hosted Point Load >

Hosted Line Load >

Hosted Area Load >

Otros parámetros
Material <>

Level >

11. Interfaz de Revit 2022

Interconexión de Gen-Revit
▪ File > Import > midas Gen MGT File

▪ File > Export > midas Gen MGT File

Revit 2022 Gen2022 v1.1 (Nueva versión)

Enviar modelo a midas Gen
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